سلام دوستان

من در اجرای wrf.exe وقتی که از دو domain استفاده می کنم همواره با این خطا مواجه میشم:

>  Namelist dfi_control not found in namelist.input. Using registry defaults
> for variables in dfi_control
>  Namelist tc not found in namelist.input. Using registry defaults for
> variables in tc
>  Namelist scm not found in namelist.input. Using registry defaults for
> variables in scm
>  Namelist fire not found in namelist.input. Using registry defaults for
> variables in fire
>  --- NOTE: sst_update is 0, setting io_form_auxinput4 = 0 and
> auxinput4_interval = 0 for all domains
>  --- NOTE: sst_update is 0, setting io_form_auxinput4 = 0 and
> auxinput4_interval = 0 for all domains
>  --- NOTE: grid_fdda is 0 for domain      1, setting gfdda interval and
> ending time to 0 for that domain.
>  --- NOTE: both grid_sfdda and pxlsm_soil_nudge are 0 for domain      1,
> setting sgfdda interval and ending time to 0 for that domain.
>  --- NOTE: obs_nudge_opt is 0 for domain      1, setting obs nudging
> interval and ending time to 0 for that domain.
>  --- NOTE: grid_fdda is 0 for domain      2, setting gfdda interval and
> ending time to 0 for that domain.
>  --- NOTE: both grid_sfdda and pxlsm_soil_nudge are 0 for domain      2,
> setting sgfdda interval and ending time to 0 for that domain.
>  --- NOTE: obs_nudge_opt is 0 for domain      2, setting obs nudging
> interval and ending time to 0 for that domain.
>  --- NOTE: num_soil_layers has been set to      4
>  -------------- FATAL CALLED ---------------
>  FATAL CALLED FROM FILE:  <stdin>  LINE:     184
>  nesting requires either an MPI build or use of the -DSTUBMPI option
>  -------------------------------------------
> STOP wrf_abort
>

در صورتی با یک domain به راحتی اجرا میشه.

ممنون میشم راهنماییم کنید.

ی., 03/08/2014 - 20:07
تصویر moje.am

این مشکل احتمالا ناشی از گزینه‌هایی هست که شما موقع configure کردن انتخاب کرده بودید. منظورم قسمتیه که سوال میکنه:

Compile for nesting? (0=no nesting, 1=basic, 2=preset moves, 3=vortex following) [default 0]: 

کدوم رو انتخاب کرده بودید؟

تصویر moje.am

بهرحال برای مشکل شما 2 راه حل پیشنهاد میشه:

1- راه حل ساده: توی namelist.input گزینه max_dom = 0 رو انجام بدید. (نمیدونم جواب میده یا نه ولی به امتحانش می‌ارزه)

2- راه حل اساسی: مدل رو ابتدا با دستور

./clean -a

کاملا پاک و از نو با گزینه درست (1=basic) کامپایل کنید.

(لطفا هر کدوم رو که انجام دادید نتیجه اش رو گزارش کنید)

تصویر asal

خیلی ممنون.

فکر می کنم با همون گزینه ی default  یعنی 0 کامپایل کردم.

چشم حتما انجام میدم و نتیجه رو به شما گزارش میدم.

تصویر asal

مشکل با راه حل دوم حل شد.

ممنون از لطف شما

برای ارسال دیدگاه وارد شوید یا ثبت نام کنید .