سلام

برای نصب wrf-chem اول پوشهchem رو در مسیر wrf کپی کردم بعد متغیر ها رو تنظیم کردم و بعد از دستور conrigure دستور  compile em_rea رو اجرا کردم که به این ارور رسیدم:

No libfl.a in /usr/lib
  check if FLEX_LIB_DIR environment variable is set correctly
       (FLEX_LIB_DIR should be the complete pathname of the FLEX library libfl.a)
   OR: Enter full path to flex library on your syste

که من فک میکنم باید متغیر دیگه ای رو هم تنظیم می کردم...

اما تو راهنمای نصبش راجع به اون متغیر چیزی ذکر نکرده بود. البته من دیدم که برای تنظیم این متغیر از یک آدرس استفاده شده که من نتونستم این آدرس رو نه با دستور find  و نه با دستور which پیدا کنم.

ممنون میشم اگر کمکم کنید.

ی., 29/12/2013 - 16:58
تصویر nixmd

شما نیاز به کتابخونه برنامه ی flex داری که با دستور زیر نصب میشه:

sudo apt-get install build-essential make cmake flex

البته توی برنامه های بالا که اسم آورده شده، flex مشکل شما رو رفع مبکنه. اما ترجیحا اونای دیگه رو هم نصب کنید چون خیلی اوقات برای کامپایل به اون ها هم نیاز میشه و تا این که شما بیاید بررسی کنید خطا از کجاست و اینها، زمان زیادی میگیره. بنابرین پیشنهاد میشه همه ی برنامه های پیشنهاد داده شده رو نصب کنید و نه فقط flex

بعد از اون فایل libfl.a توی دایرکتوری مورد نظر اضافه میشه و شما میتونید کامپایل کنید.

تصویر arezu

سلام مجدد

ممنون از راهنماییتون

بسته هایی که فرموده بودید نصب کردم. منتها خودش آدرس رو پیدا نکرد و من با دستور

export FLEX_LIB_DIR=/usr/lib/i386-linux-gnu

آدرس رو بهش دادم.

اما بعد از این کار از kpp ایراد می گیره با اینکه قبلا متغیرش رو تنظیم کردم...

این هم ارورش:

compile kpp
make[1]: Entering directory `/home/arezu/wrf/WRFV3/chem/KPP/kpp/kpp-2.1/src'
  yacc scan.y
make[1]: Leaving directory `/home/arezu/wrf/WRFV3/chem/KPP/kpp/kpp-2.1/src'

باز هم ممنون

تصویر nixmd

این پیغام خطا نیست. چیزی نمیگه که!

پیغام هارو به طور کامل بنویسیدشون. یا این که کلا هرچی خروجی بوده توی یه سرویس pastebin ارسال کنید و خروجیش رو اینجا بذارید. مثلا سرویس http://paste.ubuntu.com

تصویر moje.am

شما می‌تونید مدل رو بدون kpp هم نصب کنید و البته خیلی ساده‌تر هست. مطمئن بشید که واقعا ضروری هست که kpp رو داشته باشد یا نه.

تصویر arezu

آخه مشکل اینجاس که من برای نصب kpp دستوری نزدم. بعد از اینکه دستور compile em_real  رو زدم خودش تمام این مراحل رو انجام داد البته قبلش دستور:

export kpp = 1  وارد کردم. ممکنه به خاطر اون باشه؟؟؟

یعنی اگه این متغیر رو بهش ندم مشکل حل میشه؟؟؟

تصویر moje.am

دقیقا همینه. باید kpp رو دوباره 0 کنید. من به راحتی بدون kpp، مدل رو نصب کردم.

اما اگر واقعا kpp رو لازم دارید شاید صفحات زیر بتونن به شما کمک کنن:

http://forum.wrfforum.com/viewtopic.php?f=5&t=2655

http://forum.wrfforum.com/viewtopic.php?f=39&t=3302

http://ruc.noaa.gov/wrf/WG11/FAQ.htm

http://ruc.noaa.gov/wrf/WG11/KPP_yacc_flex_problems.pdf

تصویر arezu

ممنونم 

با این کار و با در نظر نگرفتن kpp  مراحل کامپایل طی شد و برای من فایلهای .exe رو ساخت منتها چند تا ارور هم داشت...

به نظرتون اینها طبیعیه؟؟؟؟

یا بعدا برام ایجاد مشکل می کنن؟؟؟؟

آخه فایلهای ساخته شده هم به ظاهر درستن و من تونستم اونها رو به پوشه main انتقال بدم.

 

تصویر moje.am

خداروشکر. اگر فایل‌های exe ساخته شدن یعنی همه چیز درسته. مهم همینه. اون error  ها هم احتمالا اسم فایل یا مدول باشن که برای ما دردسر نداشتن چون ما به فایلهای exe رسیدیم.

این که گفتم قبل از شروع کار مطمئن بشید چه بخش‌هایی رو لازم دارید واسه همینه که زیاد درگیر نشید.

امیدوارم kpp لازم نداشته باشه و با همین کارتون راه بیفته ;-)

تصویر arezu

بله

واقعا خداروشکر

دقیقا مربوط به مدول هاش هست. 

ممنون از لطفتون واقعا.

 

تصویر arezu

این خروجی ارورهام هست:

diffwrf.f:52.6:

  use module_ext_internal
      1
Fatal Error: Wrong module version '0' (expected '9') for file 'module_ext_internal.mod' opened at (1)
/usr/lib/gcc/i686-linux-gnu/4.7/../../../i386-linux-gnu/crt1.o: In function `_start':
(.text+0x18): undefined reference to `main'
collect2: error: ld returned 1 exit status
make[3]: [diffwrf] Error 1 (ignored)
module_domain_type.f90:3.7:

   USE module_utility
       1
Fatal Error: Wrong module version '0' (expected '9') for file 'module_utility.mod' opened at (1)
make[2]: [module_domain_type.o] Error 1 (ignored)
module_configure.f90:4.6:

  USE module_domain_type, ONLY : streamrec
      1
Fatal Error: Wrong module version '0' (expected '9') for file 'module_domain_type.mod' opened at (1)
make[2]: [module_configure.o] Error 1 (ignored)
module_alloc_space_1.f90:11.10:

      USE module_domain_type
          1
Fatal Error: Wrong module version '0' (expected '9') for file 'module_domain_type.mod' opened at (1)
module_alloc_space_0.f90:11.10:

      USE module_domain_type
          1
Fatal Error: Wrong module version '0' (expected '9') for file 'module_domain_type.mod' opened at (1)
make[2]: [module_alloc_space_1.o] Error 1 (ignored)
make[2]: [module_alloc_space_0.o] Error 1 (ignored)
module_alloc_space_3.f90:11.10:

      USE module_domain_type
          1
Fatal Error: Wrong module version '0' (expected '9') for file 'module_domain_type.mod' opened at (1)
make[2]: [module_alloc_space_3.o] Error 1 (ignored)
module_alloc_space_2.f90:11.10:

      USE module_domain_type
          1
Fatal Error: Wrong module version '0' (expected '9') for file 'module_domain_type.mod' opened at (1)
make[2]: [module_alloc_space_2.o] Error 1 (ignored)
module_alloc_space_4.f90:11.10:

      USE module_domain_type
          1
Fatal Error: Wrong module version '0' (expected '9') for file 'module_domain_type.mod' opened at (1)
make[2]: [module_alloc_space_4.o] Error 1 (ignored)
module_alloc_space_5.f90:11.10:

      USE module_domain_type
          1
Fatal Error: Wrong module version '0' (expected '9') for file 'module_domain_type.mod' opened at (1)
make[2]: [module_alloc_space_5.o] Error 1 (ignored)
module_alloc_space_6.f90:11.10:

      USE module_domain_type
          1
Fatal Error: Wrong module version '0' (expected '9') for file 'module_domain_type.mod' opened at (1)
make[2]: [module_alloc_space_6.o] Error 1 (ignored)
module_alloc_space_8.f90:11.10:

      USE module_domain_type
          1
Fatal Error: Wrong module version '0' (expected '9') for file 'module_domain_type.mod' opened at (1)
make[2]: [module_alloc_space_8.o] Error 1 (ignored)
module_alloc_space_7.f90:11.10:

      USE module_domain_type
          1
Fatal Error: Wrong module version '0' (expected '9') for file 'module_domain_type.mod' opened at (1)
make[2]: [module_alloc_space_7.o] Error 1 (ignored)
module_alloc_space_9.f90:11.10:

      USE module_domain_type
          1
Fatal Error: Wrong module version '0' (expected '9') for file 'module_domain_type.mod' opened at (1)
make[2]: [module_alloc_space_9.o] Error 1 (ignored)
yy0.f90:8.6:

  USE module_configure, ONLY : model_config_rec
      1
Fatal Error: Wrong module version '0' (expected '9') for file 'module_configure.mod' opened at (1)
yy1.f90:8.6:

  USE module_configure, ONLY : model_config_rec
      1
Fatal Error: Wrong module version '0' (expected '9') for file 'module_configure.mod' opened at (1)
make[2]: [nl_get_0_routines.o] Error 1 (ignored)
make[2]: [nl_get_1_routines.o] Error 1 (ignored)
yy3.f90:8.6:

  USE module_configure, ONLY : model_config_rec
      1
Fatal Error: Wrong module version '0' (expected '9') for file 'module_configure.mod' opened at (1)
make[2]: [nl_get_3_routines.o] Error 1 (ignored)
make[2]: [nl_get_2_routines.o] Error 1 (ignored)
yy5.f90:8.6:

  USE module_configure, ONLY : model_config_rec
      1
Fatal Error: Wrong module version '0' (expected '9') for file 'module_configure.mod' opened at (1)
yy4.f90:8.6:

  USE module_configure, ONLY : model_config_rec
      1
Fatal Error: Wrong module version '0' (expected '9') for file 'module_configure.mod' opened at (1)
make[2]: [nl_get_5_routines.o] Error 1 (ignored)
make[2]: [nl_get_4_routines.o] Error 1 (ignored)
yy7.f90:8.6:

  USE module_configure, ONLY : model_config_rec
      1
Fatal Error: Wrong module version '0' (expected '9') for file 'module_configure.mod' opened at (1)
make[2]: [nl_get_6_routines.o] Error 1 (ignored)
make[2]: [nl_get_7_routines.o] Error 1 (ignored)
xx0.f90:8.6:

  USE module_configure, ONLY : model_config_rec
      1
Fatal Error: Wrong module version '0' (expected '9') for file 'module_configure.mod' opened at (1)
make[2]: [nl_set_1_routines.o] Error 1 (ignored)
make[2]: [nl_set_0_routines.o] Error 1 (ignored)
xx2.f90:8.6:

  USE module_configure, ONLY : model_config_rec
      1
Fatal Error: Wrong module version '0' (expected '9') for file 'module_configure.mod' opened at (1)
xx3.f90:8.6:

  USE module_configure, ONLY : model_config_rec
      1
Fatal Error: Wrong module version '0' (expected '9') for file 'module_configure.mod' opened at (1)
make[2]: [nl_set_2_routines.o] Error 1 (ignored)
make[2]: [nl_set_3_routines.o] Error 1 (ignored)
xx4.f90:8.6:

  USE module_configure, ONLY : model_config_rec
      1
Fatal Error: Wrong module version '0' (expected '9') for file 'module_configure.mod' opened at (1)
make[2]: [nl_set_4_routines.o] Error 1 (ignored)
xx5.f90:8.6:

  USE module_configure, ONLY : model_config_rec
      1
Fatal Error: Wrong module version '0' (expected '9') for file 'module_configure.mod' opened at (1)
make[2]: [nl_set_5_routines.o] Error 1 (ignored)
xx6.f90:8.6:

  USE module_configure, ONLY : model_config_rec
      1
Fatal Error: Wrong module version '0' (expected '9') for file 'module_configure.mod' opened at (1)
xx7.f90:8.6:

  USE module_configure, ONLY : model_config_rec
      1
Fatal Error: Wrong module version '0' (expected '9') for file 'module_configure.mod' opened at (1)
make[2]: [nl_set_6_routines.o] Error 1 (ignored)
make[2]: [nl_set_7_routines.o] Error 1 (ignored)
module_domain.f90:4.7:

   USE module_configure
       1
Fatal Error: Wrong module version '0' (expected '9') for file 'module_configure.mod' opened at (1)
make[2]: [module_domain.o] Error 1 (ignored)
module_tiles.f90:6.6:

  USE module_configure
      1
Fatal Error: Wrong module version '0' (expected '9') for file 'module_configure.mod' opened at (1)
make[2]: [module_tiles.o] Error 1 (ignored)
module_nesting.f90:4.7:

   USE module_domain
       1
Fatal Error: Wrong module version '0' (expected '9') for file 'module_domain.mod' opened at (1)
make[2]: [module_nesting.o] Error 1 (ignored)
module_comm_dm_0.f90:10.9:

     USE module_domain, ONLY:domain
         1
Fatal Error: Wrong module version '0' (expected '9') for file 'module_domain.mod' opened at (1)
make[2]: [module_comm_dm_0.o] Error 1 (ignored)
module_comm_nesting_dm.f90:10.9:

     USE module_domain, ONLY:domain
         1
Fatal Error: Wrong module version '0' (expected '9') for file 'module_domain.mod' opened at (1)
make[2]: [module_comm_nesting_dm.o] Error 1 (ignored)
module_comm_dm_1.f90:10.9:

     USE module_domain, ONLY:domain
         1
Fatal Error: Wrong module version '0' (expected '9') for file 'module_domain.mod' opened at (1)
make[2]: [module_comm_dm_1.o] Error 1 (ignored)
module_comm_dm_2.f90:10.9:

     USE module_domain, ONLY:domain
         1
Fatal Error: Wrong module version '0' (expected '9') for file 'module_domain.mod' opened at (1)
make[2]: [module_comm_dm_2.o] Error 1 (ignored)
module_comm_dm_3.f90:10.9:

     USE module_domain, ONLY:domain
         1
Fatal Error: Wrong module version '0' (expected '9') for file 'module_domain.mod' opened at (1)
make[2]: [module_comm_dm_3.o] Error 1 (ignored)
module_integrate.f90:12.7:

   USE module_domain
       1
Fatal Error: Wrong module version '0' (expected '9') for file 'module_domain.mod' opened at (1)
make[2]: [module_integrate.o] Error 1 (ignored)
module_comm_dm_4.f90:10.9:

     USE module_domain, ONLY:domain
         1
Fatal Error: Wrong module version '0' (expected '9') for file 'module_domain.mod' opened at (1)
make[2]: [module_comm_dm_4.o] Error 1 (ignored)
module_comm_dm.f90:2.7:

   USE module_comm_dm_0
       1
Fatal Error: Wrong module version '0' (expected '9') for file 'module_comm_dm_0.mod' opened at (1)
make[2]: [module_comm_dm.o] Error 1 (ignored)
module_dm.f90:20.7:

   USE module_wrf_error
       1
Fatal Error: Wrong module version '0' (expected '9') for file 'module_wrf_error.mod' opened at (1)
make[2]: [module_dm.o] Error 1 (ignored)
module_io_quilt.f90:2.6:

  USE module_internal_header_util
      1
Fatal Error: Wrong module version '0' (expected '9') for file 'module_internal_header_util.mod' opened at (1)
make[2]: [module_io_quilt.o] Error 1 (ignored)
module_io.f90:2.6:

  USE module_configure
      1
Fatal Error: Wrong module version '0' (expected '9') for file 'module_configure.mod' opened at (1)
make[2]: [module_io.o] Error 1 (ignored)
ar: creating ../main/libwrflib.a
ar: module_domain_type.o: No such file or directory
make[2]: [framework] Error 1 (ignored)
ranlib: '../main/libwrflib.a': No such file
make[2]: [framework] Error 1 (ignored)
diffwrf.f:52.6:

  use module_ext_internal
      1
Fatal Error: Wrong module version '0' (expected '9') for file 'module_ext_internal.mod' opened at (1)
/usr/lib/gcc/i686-linux-gnu/4.7/../../../i386-linux-gnu/crt1.o: In function `_start':
(.text+0x18): undefined reference to `main'
collect2: error: ld returned 1 exit status
make[2]: [diffwrf] Error 1 (ignored)
../frame/module_dm.f90:3.7:

   USE module_wrf_error
       1
Fatal Error: Wrong module version '0' (expected '9') for file 'module_wrf_error.mod' opened at (1)
make[2]: [../frame/module_dm.o] Error 1 (ignored)
../frame/module_io.f90:2.6:

  USE module_configure
      1
Fatal Error: Wrong module version '0' (expected '9') for file 'module_configure.mod' opened at (1)
make[2]: [../frame/module_io.o] Error 1 (ignored)
../frame/module_domain.f90:4.7:

   USE module_configure
       1
Fatal Error: Wrong module version '0' (expected '9') for file 'module_configure.mod' opened at (1)
make[2]: [../frame/module_domain.o] Error 1 (ignored)
../frame/module_nesting.f90:4.7:

   USE module_domain
       1
Fatal Error: Wrong module version '0' (expected '9') for file 'module_domain.mod' opened at (1)
make[2]: [../frame/module_nesting.o] Error 1 (ignored)
../frame/module_tiles.f90:2.6:

  USE module_configure
      1
Fatal Error: Wrong module version '0' (expected '9') for file 'module_configure.mod' opened at (1)
make[2]: [../frame/module_tiles.o] Error 1 (ignored)
../frame/module_io_quilt.f90:2.6:

  USE module_internal_header_util
      1
Fatal Error: Wrong module version '0' (expected '9') for file 'module_internal_header_util.mod' opened at (1)
make[2]: [../frame/module_io_quilt.o] Error 1 (ignored)
wrf_ext_write_field.f90:18.8:

    USE module_io
        1
Fatal Error: Wrong module version '0' (expected '9') for file 'module_io.mod' opened at (1)
make[2]: [wrf_ext_write_field.o] Error 1 (ignored)
wrf_ext_read_field.f90:15.8:

    USE module_io
        1
Fatal Error: Wrong module version '0' (expected '9') for file 'module_io.mod' opened at (1)
make[2]: [wrf_ext_read_field.o] Error 1 (ignored)
../frame/module_configure.f90:4.6:

  USE module_domain_type, ONLY : streamrec
      1
Fatal Error: Wrong module version '0' (expected '9') for file 'module_domain_type.mod' opened at (1)
make[2]: [../frame/module_configure.o] Error 1 (ignored)
wrf_tsin.f90:3.8:

    USE module_domain
        1
Fatal Error: Wrong module version '0' (expected '9') for file 'module_domain.mod' opened at (1)
make[2]: [wrf_tsin.o] Error 1 (ignored)
set_timekeeping.f90:2.7:

   USE module_domain
       1
Fatal Error: Wrong module version '0' (expected '9') for file 'module_domain.mod' opened at (1)
make[2]: [set_timekeeping.o] Error 1 (ignored)
interp_fcn.f90:15.9:

     USE module_configure
         1
Fatal Error: Wrong module version '0' (expected '9') for file 'module_configure.mod' opened at (1)
make[2]: [interp_fcn.o] Error 1 (ignored)
module_bc.f90:2.7:

   USE module_configure
       1
Fatal Error: Wrong module version '0' (expected '9') for file 'module_configure.mod' opened at (1)
module_date_time.f90:2.6:

  USE module_wrf_error
      1
Fatal Error: Wrong module version '0' (expected '9') for file 'module_wrf_error.mod' opened at (1)
make[2]: [module_bc.o] Error 1 (ignored)
make[2]: [module_date_time.o] Error 1 (ignored)
mediation_interp_domain.f90:2.7:

   USE module_domain
       1
Fatal Error: Wrong module version '0' (expected '9') for file 'module_domain.mod' opened at (1)
make[2]: [mediation_interp_domain.o] Error 1 (ignored)
mediation_force_domain.f90:2.7:

   USE module_domain
       1
Fatal Error: Wrong module version '0' (expected '9') for file 'module_domain.mod' opened at (1)
make[2]: [mediation_force_domain.o] Error 1 (ignored)
mediation_feedback_domain.f90:2.7:

   USE module_domain
       1
Fatal Error: Wrong module version '0' (expected '9') for file 'module_domain.mod' opened at (1)
make[2]: [mediation_feedback_domain.o] Error 1 (ignored)
solve_interface.f90:6.7:

   USE module_domain
       1
Fatal Error: Wrong module version '0' (expected '9') for file 'module_domain.mod' opened at (1)
make[2]: [solve_interface.o] Error 1 (ignored)
wrf_timeseries.f90:2.7:

   USE module_domain, ONLY : domain, get_ijk_from_grid
       1
Fatal Error: Wrong module version '0' (expected '9') for file 'module_domain.mod' opened at (1)
make[2]: [wrf_timeseries.o] Error 1 (ignored)
wrf_fddaobs_in.f90:37.8:

    USE module_domain
        1
Fatal Error: Wrong module version '0' (expected '9') for file 'module_domain.mod' opened at (1)
make[2]: [wrf_fddaobs_in.o] Error 1 (ignored)
module_io_wrf.f90:6.6:

  USE module_wrf_error
      1
Fatal Error: Wrong module version '0' (expected '9') for file 'module_wrf_error.mod' opened at (1)
make[2]: [module_io_wrf.o] Error 1 (ignored)
module_check_a_mundo.f90:3.10:

      USE module_wrf_error
          1
Fatal Error: Wrong module version '0' (expected '9') for file 'module_wrf_error.mod' opened at (1)
make[2]: [module_check_a_mundo.o] Error 1 (ignored)
start_domain.f90:6.7:

   USE module_domain
       1
Fatal Error: Wrong module version '0' (expected '9') for file 'module_domain.mod' opened at (1)
make[2]: [start_domain.o] Error 1 (ignored)
module_soil_pre.f90:2.7:

   USE module_date_time
       1
Fatal Error: Wrong module version '0' (expected '9') for file 'module_date_time.mod' opened at (1)
make[2]: [module_soil_pre.o] Error 1 (ignored)
init_modules.f90:2.5:

 USE module_bc , ONLY : init_module_bc
     1
Fatal Error: Wrong module version '0' (expected '9') for file 'module_bc.mod' opened at (1)
make[2]: [init_modules.o] Error 1 (ignored)
input_wrf.f90:2.8:

    USE module_domain
        1
Fatal Error: Wrong module version '0' (expected '9') for file 'module_domain.mod' opened at (1)
make[2]: [input_wrf.o] Error 1 (ignored)
output_wrf.f90:4.8:

    USE module_io
        1
Fatal Error: Wrong module version '0' (expected '9') for file 'module_io.mod' opened at (1)
make[2]: [output_wrf.o] Error 1 (ignored)
wrf_bdyout.f90:3.8:

    USE module_io
        1
Fatal Error: Wrong module version '0' (expected '9') for file 'module_io.mod' opened at (1)
make[2]: [wrf_bdyout.o] Error 1 (ignored)
wrf_bdyin.f90:2.8:

    USE module_domain
        1
Fatal Error: Wrong module version '0' (expected '9') for file 'module_domain.mod' opened at (1)
make[2]: [wrf_bdyin.o] Error 1 (ignored)
module_io_domain.f90:2.4:

USE module_io
    1
Fatal Error: Wrong module version '0' (expected '9') for file 'module_io.mod' opened at (1)
make[2]: [module_io_domain.o] Error 1 (ignored)
module_optional_input.f90:28.10:

      USE module_domain , ONLY : domain
          1
Fatal Error: Wrong module version '0' (expected '9') for file 'module_domain.mod' opened at (1)
make[2]: [module_optional_input.o] Error 1 (ignored)
dfi.f90:2.10:

      USE module_domain, ONLY : domain
          1
Fatal Error: Wrong module version '0' (expected '9') for file 'module_domain.mod' opened at (1)
make[2]: [dfi.o] Error 1 (ignored)
mediation_nest_move.f90:2.7:

   USE module_domain, ONLY : domain, get_ijk_from_grid, adjust_domain_dims_for_
       1
Fatal Error: Wrong module version '0' (expected '9') for file 'module_domain.mod' opened at (1)
make[2]: [mediation_nest_move.o] Error 1 (ignored)
mediation_integrate.f90:2.7:

   USE module_domain , ONLY : domain, domain_clock_get
       1
Fatal Error: Wrong module version '0' (expected '9') for file 'module_domain.mod' opened at (1)
make[2]: [mediation_integrate.o] Error 1 (ignored)
mediation_wrfmain.f90:2.7:

   USE module_domain
       1
Fatal Error: Wrong module version '0' (expected '9') for file 'module_domain.mod' opened at (1)
make[2]: [mediation_wrfmain.o] Error 1 (ignored)
ar: creating ../main/libwrflib.a
ar: module_bc.o: No such file or directory
make[2]: [shared] Error 1 (ignored)
../frame/module_dm.f90:3.7:

   USE module_wrf_error
       1
Fatal Error: Wrong module version '0' (expected '9') for file 'module_wrf_error.mod' opened at (1)
make[3]: [../frame/module_dm.o] Error 1 (ignored)
../frame/module_domain.f90:4.7:

   USE module_configure
       1
Fatal Error: Wrong module version '0' (expected '9') for file 'module_configure.mod' opened at (1)
make[3]: [../frame/module_domain.o] Error 1 (ignored)
../frame/module_comm_dm.f90:2.7:

   USE module_comm_dm_0
       1
Fatal Error: Wrong module version '0' (expected '9') for file 'module_comm_dm_0.mod' opened at (1)
make[3]: [../frame/module_comm_dm.o] Error 1 (ignored)
module_shallowcu_driver.f90:33.7:

   USE module_model_constants
       1
Fatal Error: Wrong module version '0' (expected '9') for file 'module_model_constants.mod' opened at (1)
make[3]: [module_shallowcu_driver.o] Error 1 (ignored)
../share/module_bc.f90:2.7:

   USE module_configure
       1
Fatal Error: Wrong module version '0' (expected '9') for file 'module_configure.mod' opened at (1)
make[3]: [../share/module_bc.o] Error 1 (ignored)
module_diagnostics.f90:28.6:

  USE module_dm, ONLY: wrf_dm_sum_real, wrf_dm_maxval
      1
Fatal Error: Wrong module version '0' (expected '9') for file 'module_dm.mod' opened at (1)
make[3]: [module_diagnostics.o] Error 1 (ignored)
module_fddaobs_driver.f90:29.6:

  USE module_domain
      1
Fatal Error: Wrong module version '0' (expected '9') for file 'module_domain.mod' opened at (1)
make[3]: [module_fddaobs_driver.o] Error 1 (ignored)
module_fr_sfire_driver.f90:2.4:

use module_fr_sfire_model
    1
Fatal Error: Wrong module version '0' (expected '9') for file 'module_fr_sfire_model.mod' opened at (1)
make[3]: [module_fr_sfire_driver.o] Error 1 (ignored)
module_ra_rrtm.f90:4882.4:

USE module_wrf_error
    1
Fatal Error: Wrong module version '0' (expected '9') for file 'module_wrf_error.mod' opened at (1)
make[3]: [module_ra_rrtm.o] Error 1 (ignored)
module_ra_gfdleta.f90:2.10:

      USE MODULE_CONFIGURE,ONLY : GRID_CONFIG_REC_TYPE
          1
Fatal Error: Wrong module version '0' (expected '9') for file 'module_configure.mod' opened at (1)
make[3]: [module_ra_gfdleta.o] Error 1 (ignored)
module_ra_HWRF.f90:2.10:

      USE MODULE_CONFIGURE,ONLY : GRID_CONFIG_REC_TYPE
          1
Fatal Error: Wrong module version '0' (expected '9') for file 'module_configure.mod' opened at (1)
make[3]: [module_ra_HWRF.o] Error 1 (ignored)
module_fdda_spnudging.f90:2.6:

  USE module_dm , ONLY : ntasks_x, ntasks_y, local_communicator_x, local_commun
      1
Fatal Error: Wrong module version '0' (expected '9') for file 'module_dm.mod' opened at (1)
make[3]: [module_fdda_spnudging.o] Error 1 (ignored)
../frame/module_configure.f90:4.6:

  USE module_domain_type, ONLY : streamrec
      1
Fatal Error: Wrong module version '0' (expected '9') for file 'module_domain_type.mod' opened at (1)
make[3]: [../frame/module_configure.o] Error 1 (ignored)
module_fr_sfire_driver_wrf.f90:2.4:

use module_fr_sfire_driver
    1
Fatal Error: Wrong module version '0' (expected '9') for file 'module_fr_sfire_driver.mod' opened at (1)
make[3]: [module_fr_sfire_driver_wrf.o] Error 1 (ignored)
module_physics_addtendc.f90:3.7:

   USE module_configure
       1
Fatal Error: Wrong module version '0' (expected '9') for file 'module_configure.mod' opened at (1)
make[3]: [module_physics_addtendc.o] Error 1 (ignored)
module_physics_init.f90:3.7:

   USE module_model_constants
       1
Fatal Error: Wrong module version '0' (expected '9') for file 'module_model_constants.mod' opened at (1)
make[3]: [module_physics_init.o] Error 1 (ignored)
module_pbl_driver.f90:60.7:

   USE module_wind_generic, ONLY : windspec
       1
Fatal Error: Wrong module version '0' (expected '9') for file 'module_wind_generic.mod' opened at (1)
make[3]: [module_pbl_driver.o] Error 1 (ignored)
module_cumulus_driver.f90:51.7:

   USE module_model_constants
       1
Fatal Error: Wrong module version '0' (expected '9') for file 'module_model_constants.mod' opened at (1)
make[3]: [module_cumulus_driver.o] Error 1 (ignored)
module_radiation_driver.f90:109.7:

   USE module_model_constants
       1
Fatal Error: Wrong module version '0' (expected '9') for file 'module_model_constants.mod' opened at (1)
make[3]: [module_radiation_driver.o] Error 1 (ignored)
module_surface_driver.f90:95.7:

   USE module_model_constants
       1
Fatal Error: Wrong module version '0' (expected '9') for file 'module_model_constants.mod' opened at (1)
make[3]: [module_surface_driver.o] Error 1 (ignored)
module_fddagd_driver.f90:29.7:

   USE module_configure
       1
Fatal Error: Wrong module version '0' (expected '9') for file 'module_configure.mod' opened at (1)
make[3]: [module_fddagd_driver.o] Error 1 (ignored)
module_mixactivate.f90:173.6:

  USE module_model_constants, only: g, rhowater, xlv, cp, rvovrd, r_d, r_v, mwd
      1
Fatal Error: Wrong module version '0' (expected '9') for file 'module_model_constants.mod' opened at (1)
make[3]: [module_mixactivate.o] Error 1 (ignored)
module_microphysics_driver.f90:45.7:

   USE module_model_constants
       1
Fatal Error: Wrong module version '0' (expected '9') for file 'module_model_constants.mod' opened at (1)
make[3]: [module_microphysics_driver.o] Error 1 (ignored)
ar: creating ../main/libwrflib.a
ar: module_ra_rrtm.o: No such file or directory
make[2]: [physics] Error 1 (ignored)
module_chem_utilities.f90:2.7:

   USE module_domain
       1
Fatal Error: Wrong module version '0' (expected '9') for file 'module_domain.mod' opened at (1)
make[2]: [module_chem_utilities.o] Error 1 (ignored)
module_chem_plumerise_scalar.f90:2.6:

  use module_model_constants
      1
Fatal Error: Wrong module version '0' (expected '9') for file 'module_model_constants.mod' opened at (1)
make[2]: [module_chem_plumerise_scalar.o] Error 1 (ignored)
module_mosaic_addemiss.f90:12.7:

   USE module_configure, only: grid_config_rec_type
       1
Fatal Error: Wrong module version '0' (expected '9') for file 'module_configure.mod' opened at (1)
make[2]: [module_mosaic_addemiss.o] Error 1 (ignored)
module_radm.f90:17.6:

  USE module_configure
      1
Fatal Error: Wrong module version '0' (expected '9') for file 'module_configure.mod' opened at (1)
make[2]: [module_radm.o] Error 1 (ignored)
module_dep_simple.f90:697: Error: Can't open included file 'netcdf.inc'
make[2]: [module_dep_simple.o] Error 1 (ignored)
module_add_emiss_burn.f90:9.6:

  USE module_configure, only: grid_config_rec_type
      1
Fatal Error: Wrong module version '0' (expected '9') for file 'module_configure.mod' opened at (1)
module_aer_opt_out.f90:16.4:

USE module_configure, only:p_extcof3,p_extcof55,p_extcof106,p_extcof3_5,p_extco
    1
Fatal Error: Wrong module version '0' (expected '9') for file 'module_configure.mod' opened at (1)
make[2]: [module_aer_opt_out.o] Error 1 (ignored)
make[2]: [module_add_emiss_burn.o] Error 1 (ignored)
module_gocart_dust.f90:10.6:

  USE module_configure
      1
Fatal Error: Wrong module version '0' (expected '9') for file 'module_configure.mod' opened at (1)
make[2]: [module_gocart_dust.o] Error 1 (ignored)
module_phot_mad.f90:1027.7:

   USE module_configure
       1
Fatal Error: Wrong module version '0' (expected '9') for file 'module_configure.mod' opened at (1)
make[2]: [module_phot_mad.o] Error 1 (ignored)
module_gocart_seasalt.f90:9.6:

  USE module_configure
      1
Fatal Error: Wrong module version '0' (expected '9') for file 'module_configure.mod' opened at (1)
make[2]: [module_gocart_seasalt.o] Error 1 (ignored)
module_gocart_dmsemis.f90:10.6:

  USE module_configure
      1
Fatal Error: Wrong module version '0' (expected '9') for file 'module_configure.mod' opened at (1)
make[2]: [module_gocart_dmsemis.o] Error 1 (ignored)
module_gocart_aerosols.f90:2.6:

  USE module_model_constants, only: mwdry
      1
Fatal Error: Wrong module version '0' (expected '9') for file 'module_model_constants.mod' opened at (1)
module_gocart_settling.f90:9.6:

  USE module_configure
      1
Fatal Error: Wrong module version '0' (expected '9') for file 'module_configure.mod' opened at (1)
make[2]: [module_gocart_aerosols.o] Error 1 (ignored)
make[2]: [module_gocart_settling.o] Error 1 (ignored)
module_gocart_drydep.f90:11.6:

  USE module_model_constants
      1
Fatal Error: Wrong module version '0' (expected '9') for file 'module_model_constants.mod' opened at (1)
make[2]: [module_gocart_drydep.o] Error 1 (ignored)
module_bioemi_simple.f90:17.6:

  USE module_configure
      1
Fatal Error: Wrong module version '0' (expected '9') for file 'module_configure.mod' opened at (1)
make[2]: [module_bioemi_simple.o] Error 1 (ignored)
module_cbmz.f90:14.7:

   USE module_configure, only: grid_config_rec_type, num_moist, num_chem, &
       1
Fatal Error: Wrong module version '0' (expected '9') for file 'module_configure.mod' opened at (1)
make[2]: [module_cbmz.o] Error 1 (ignored)
module_bioemi_beis313.f90:15.6:

  USE module_configure
      1
Fatal Error: Wrong module version '0' (expected '9') for file 'module_configure.mod' opened at (1)
make[2]: [module_bioemi_beis313.o] Error 1 (ignored)
module_bioemi_megan2.f90:26.8:

    USE module_configure
        1
Fatal Error: Wrong module version '0' (expected '9') for file 'module_configure.mod' opened at (1)
make[2]: [module_bioemi_megan2.o] Error 1 (ignored)
module_add_emis_cptec.f90:8.6:

  USE module_configure
      1
Fatal Error: Wrong module version '0' (expected '9') for file 'module_configure.mod' opened at (1)
make[2]: [module_add_emis_cptec.o] Error 1 (ignored)
module_ftuv_driver.f90:366: Error: Can't open included file 'netcdf.inc'
make[2]: [module_ftuv_driver.o] Error 1 (ignored)
module_ctrans_grell.f90:2.4:

USE module_cu_gd
    1
Fatal Error: Wrong module version '0' (expected '9') for file 'module_cu_gd.mod' opened at (1)
make[2]: [module_ctrans_grell.o] Error 1 (ignored)
module_optical_averaging.f90:16.7:

   USE module_configure
       1
Fatal Error: Wrong module version '0' (expected '9') for file 'module_configure.mod' opened at (1)
make[2]: [module_optical_averaging.o] Error 1 (ignored)
module_mosaic_initmixrats.f90:11.5:

 use module_configure, only: grid_config_rec_type
     1
Fatal Error: Wrong module version '0' (expected '9') for file 'module_configure.mod' opened at (1)
make[2]: [module_mosaic_initmixrats.o] Error 1 (ignored)
module_ltng_crm.f90:21.6:

  USE module_dm , only : wrf_dm_max_real, wrf_dm_min_real, wrf_dm_sum_real
      1
Fatal Error: Wrong module version '0' (expected '9') for file 'module_dm.mod' opened at (1)
make[2]: [module_ltng_crm.o] Error 1 (ignored)
../phys/module_mixactivate.f90:173.6:

  USE module_model_constants, only: g, rhowater, xlv, cp, rvovrd, r_d, r_v, mwd
      1
Fatal Error: Wrong module version '0' (expected '9') for file 'module_model_constants.mod' opened at (1)
make[2]: [../phys/module_mixactivate.o] Error 1 (ignored)
optical_driver.f90:12.7:

   USE module_configure
       1
Fatal Error: Wrong module version '0' (expected '9') for file 'module_configure.mod' opened at (1)
make[2]: [optical_driver.o] Error 1 (ignored)
module_plumerise1.f90:14.6:

  USE module_configure
      1
Fatal Error: Wrong module version '0' (expected '9') for file 'module_configure.mod' opened at (1)
make[2]: [module_plumerise1.o] Error 1 (ignored)
module_mosaic_wetscav.f90:10.7:

   USE module_configure, only: grid_config_rec_type
       1
Fatal Error: Wrong module version '0' (expected '9') for file 'module_configure.mod' opened at (1)
make[2]: [module_mosaic_wetscav.o] Error 1 (ignored)
module_gocart_chem.f90:10.6:

  USE module_configure
      1
Fatal Error: Wrong module version '0' (expected '9') for file 'module_configure.mod' opened at (1)
make[2]: [module_gocart_chem.o] Error 1 (ignored)
module_mixactivate_wrappers.f90:12.8:

    USE module_configure, only: grid_config_rec_type
        1
Fatal Error: Wrong module version '0' (expected '9') for file 'module_configure.mod' opened at (1)
make[2]: [module_mixactivate_wrappers.o] Error 1 (ignored)
module_lightning_driver.f90:21.7:

   USE module_model_constants
       1
Fatal Error: Wrong module version '0' (expected '9') for file 'module_model_constants.mod' opened at (1)
make[2]: [module_lightning_driver.o] Error 1 (ignored)
module_mosaic_driver.f90:10.5:

 use module_configure, only: grid_config_rec_type, &
     1
Fatal Error: Wrong module version '0' (expected '9') for file 'module_configure.mod' opened at (1)
make[2]: [module_mosaic_driver.o] Error 1 (ignored)
module_mosaic_drydep.f90:12.5:

 use module_configure, only: grid_config_rec_type, num_moist, num_chem
     1
Fatal Error: Wrong module version '0' (expected '9') for file 'module_configure.mod' opened at (1)
make[2]: [module_mosaic_drydep.o] Error 1 (ignored)
module_phot_fastj.f90:20.7:

   USE module_configure
       1
Fatal Error: Wrong module version '0' (expected '9') for file 'module_configure.mod' opened at (1)
make[2]: [module_phot_fastj.o] Error 1 (ignored)
module_aerosols_sorgam.f90:5.6:

  USE module_radm
      1
Fatal Error: Can't open module file 'module_radm.mod' for reading at (1): No such file or directory
make[2]: [module_aerosols_sorgam.o] Error 1 (ignored)
photolysis_driver.f90:25.7:

   USE module_configure
       1
Fatal Error: Wrong module version '0' (expected '9') for file 'module_configure.mod' opened at (1)
make[2]: [photolysis_driver.o] Error 1 (ignored)
module_mosaic_cloudchem.f90:23.5:

 use module_configure, only: grid_config_rec_type
     1
Fatal Error: Wrong module version '0' (expected '9') for file 'module_configure.mod' opened at (1)
make[2]: [module_mosaic_cloudchem.o] Error 1 (ignored)
mechanism_driver.f90:16.6:

  USE module_configure
      1
Fatal Error: Wrong module version '0' (expected '9') for file 'module_configure.mod' opened at (1)
make[2]: [mechanism_driver.o] Error 1 (ignored)
aerosol_driver.f90:10.7:

   USE module_configure
       1
Fatal Error: Wrong module version '0' (expected '9') for file 'module_configure.mod' opened at (1)
make[2]: [aerosol_driver.o] Error 1 (ignored)
module_input_chem_data.f90:2.7:

   USE module_io_domain
       1
Fatal Error: Wrong module version '0' (expected '9') for file 'module_io_domain.mod' opened at (1)
module_sorgam_cloudchem.f90:24.5:

 use module_configure, only: grid_config_rec_type
     1
Fatal Error: Wrong module version '0' (expected '9') for file 'module_configure.mod' opened at (1)
make[2]: [module_input_chem_data.o] Error 1 (ignored)
make[2]: [module_sorgam_cloudchem.o] Error 1 (ignored)
module_cbm4_addemiss.f90:9.6:

  USE module_configure
      1
Fatal Error: Wrong module version '0' (expected '9') for file 'module_configure.mod' opened at (1)
module_cbmz_addemiss.f90:9.6:

  USE module_configure
      1
Fatal Error: Wrong module version '0' (expected '9') for file 'module_configure.mod' opened at (1)
make[2]: [module_cbm4_addemiss.o] Error 1 (ignored)
make[2]: [module_cbmz_addemiss.o] Error 1 (ignored)
module_input_dust_errosion.f90:2.8:

    USE module_io_domain
        1
Fatal Error: Wrong module version '0' (expected '9') for file 'module_io_domain.mod' opened at (1)
make[2]: [module_input_dust_errosion.o] Error 1 (ignored)
module_input_chem_bioemiss.f90:2.8:

    USE module_io_domain
        1
Fatal Error: Wrong module version '0' (expected '9') for file 'module_io_domain.mod' opened at (1)
make[2]: [module_input_chem_bioemiss.o] Error 1 (ignored)
module_input_gocart_dms.f90:2.8:

    USE module_io_domain
        1
Fatal Error: Wrong module version '0' (expected '9') for file 'module_io_domain.mod' opened at (1)
make[2]: [module_input_gocart_dms.o] Error 1 (ignored)
module_emissions_anthropogenics.f90:8.6:

  USE module_configure
      1
Fatal Error: Wrong module version '0' (expected '9') for file 'module_configure.mod' opened at (1)
make[2]: [module_emissions_anthropogenics.o] Error 1 (ignored)
module_cbmz_initmixrats.f90:12.7:

   USE module_configure, only: grid_config_rec_type, num_chem, &
       1
Fatal Error: Wrong module version '0' (expected '9') for file 'module_configure.mod' opened at (1)
make[2]: [module_cbmz_initmixrats.o] Error 1 (ignored)
module_cbm4_initmixrats.f90:12.8:

    USE module_configure, only: grid_config_rec_type, num_chem, &
        1
Fatal Error: Wrong module version '0' (expected '9') for file 'module_configure.mod' opened at (1)
make[2]: [module_cbm4_initmixrats.o] Error 1 (ignored)
module_wetscav_driver.f90:12.7:

   USE module_configure
       1
Fatal Error: Wrong module version '0' (expected '9') for file 'module_configure.mod' opened at (1)
make[2]: [module_wetscav_driver.o] Error 1 (ignored)
module_aer_drydep.f90:15.5:

 use module_configure, only: grid_config_rec_type, num_moist, num_chem
     1
Fatal Error: Wrong module version '0' (expected '9') for file 'module_configure.mod' opened at (1)
make[2]: [module_aer_drydep.o] Error 1 (ignored)
chemics_init.f90:19.7:

   USE module_domain
       1
Fatal Error: Wrong module version '0' (expected '9') for file 'module_domain.mod' opened at (1)
make[2]: [chemics_init.o] Error 1 (ignored)
emissions_driver.f90:47.6:

  USE module_configure
      1
Fatal Error: Wrong module version '0' (expected '9') for file 'module_configure.mod' opened at (1)
make[2]: [emissions_driver.o] Error 1 (ignored)
cloudchem_driver.f90:9.7:

   USE module_configure
       1
Fatal Error: Wrong module version '0' (expected '9') for file 'module_configure.mod' opened at (1)
make[2]: [cloudchem_driver.o] Error 1 (ignored)
dry_dep_driver.f90:18.6:

  USE module_model_constants
      1
Fatal Error: Wrong module version '0' (expected '9') for file 'module_model_constants.mod' opened at (1)
make[2]: [dry_dep_driver.o] Error 1 (ignored)
chem_driver.F:1009:0: fatal error: call_to_kpp_mech_drive.inc: No such file or directory
compilation terminated.
make[2]: [chem_driver.o] Error 1 (ignored)
chem_driver.f90:10.6:

  USE module_domain
      1
Fatal Error: Wrong module version '0' (expected '9') for file 'module_domain.mod' opened at (1)
make[2]: [chem_driver.o] Error 1 (ignored)
ar: creating ../main/libwrflib.a
ar: module_chem_utilities.o: No such file or directory
make[2]: [chemics] Error 1 (ignored)
/bin/sh: 4: ../chem/module_gocart_aerosols.o: not found
make[1]: [em_core] Error 127 (ignored)
../share/module_bc.f90:2.7:

   USE module_configure
       1
Fatal Error: Wrong module version '0' (expected '9') for file 'module_configure.mod' opened at (1)
make[2]: [../share/module_bc.o] Error 1 (ignored)
../frame/module_domain.f90:4.7:

   USE module_configure
       1
Fatal Error: Wrong module version '0' (expected '9') for file 'module_configure.mod' opened at (1)
make[2]: [../frame/module_domain.o] Error 1 (ignored)
../phys/module_radiation_driver.f90:109.7:

   USE module_model_constants
       1
Fatal Error: Wrong module version '0' (expected '9') for file 'module_model_constants.mod' opened at (1)
make[2]: [../phys/module_radiation_driver.o] Error 1 (ignored)
../phys/module_surface_driver.f90:95.7:

   USE module_model_constants
       1
Fatal Error: Wrong module version '0' (expected '9') for file 'module_model_constants.mod' opened at (1)
make[2]: [../phys/module_surface_driver.o] Error 1 (ignored)
../phys/module_cumulus_driver.f90:51.7:

   USE module_model_constants
       1
Fatal Error: Wrong module version '0' (expected '9') for file 'module_model_constants.mod' opened at (1)
make[2]: [../phys/module_cumulus_driver.o] Error 1 (ignored)
../phys/module_shallowcu_driver.f90:33.7:

   USE module_model_constants
       1
Fatal Error: Wrong module version '0' (expected '9') for file 'module_model_constants.mod' opened at (1)
make[2]: [../phys/module_shallowcu_driver.o] Error 1 (ignored)
../phys/module_pbl_driver.f90:60.7:

   USE module_wind_generic, ONLY : windspec
       1
Fatal Error: Wrong module version '0' (expected '9') for file 'module_wind_generic.mod' opened at (1)
make[2]: [../phys/module_pbl_driver.o] Error 1 (ignored)
../frame/module_comm_dm.f90:2.7:

   USE module_comm_dm_0
       1
Fatal Error: Wrong module version '0' (expected '9') for file 'module_comm_dm_0.mod' opened at (1)
make[2]: [../frame/module_comm_dm.o] Error 1 (ignored)
../phys/module_fddagd_driver.f90:29.7:

   USE module_configure
       1
Fatal Error: Wrong module version '0' (expected '9') for file 'module_configure.mod' opened at (1)
make[2]: [../phys/module_fddagd_driver.o] Error 1 (ignored)
../frame/module_tiles.f90:2.6:

  USE module_configure
      1
Fatal Error: Wrong module version '0' (expected '9') for file 'module_configure.mod' opened at (1)
make[2]: [../frame/module_tiles.o] Error 1 (ignored)
../frame/module_dm.f90:3.7:

   USE module_wrf_error
       1
Fatal Error: Wrong module version '0' (expected '9') for file 'module_wrf_error.mod' opened at (1)
make[2]: [../frame/module_dm.o] Error 1 (ignored)
../phys/module_fddaobs_driver.f90:29.6:

  USE module_domain
      1
Fatal Error: Wrong module version '0' (expected '9') for file 'module_domain.mod' opened at (1)
make[2]: [../phys/module_fddaobs_driver.o] Error 1 (ignored)
../phys/module_microphysics_driver.f90:45.7:

   USE module_model_constants
       1
Fatal Error: Wrong module version '0' (expected '9') for file 'module_model_constants.mod' opened at (1)
make[2]: [../phys/module_microphysics_driver.o] Error 1 (ignored)
../phys/module_physics_addtendc.f90:3.7:

   USE module_configure
       1
Fatal Error: Wrong module version '0' (expected '9') for file 'module_configure.mod' opened at (1)
make[2]: [../phys/module_physics_addtendc.o] Error 1 (ignored)
../frame/module_configure.f90:4.6:

  USE module_domain_type, ONLY : streamrec
      1
Fatal Error: Wrong module version '0' (expected '9') for file 'module_domain_type.mod' opened at (1)
make[2]: [../frame/module_configure.o] Error 1 (ignored)
../share/module_io_domain.f90:2.4:

USE module_io
    1
Fatal Error: Wrong module version '0' (expected '9') for file 'module_io.mod' opened at (1)
make[2]: [../share/module_io_domain.o] Error 1 (ignored)
../share/module_date_time.f90:2.6:

  USE module_wrf_error
      1
Fatal Error: Wrong module version '0' (expected '9') for file 'module_wrf_error.mod' opened at (1)
make[2]: [../share/module_date_time.o] Error 1 (ignored)
couple_or_uncouple_em.f90:10.7:

   USE module_domain, ONLY : domain, get_ijk_from_grid
       1
Fatal Error: Wrong module version '0' (expected '9') for file 'module_domain.mod' opened at (1)
make[2]: [couple_or_uncouple_em.o] Error 1 (ignored)
nest_init_utils.f90:2.7:

   USE module_domain, ONLY : domain
       1
Fatal Error: Wrong module version '0' (expected '9') for file 'module_domain.mod' opened at (1)
make[2]: [nest_init_utils.o] Error 1 (ignored)
../phys/module_physics_init.f90:3.7:

   USE module_model_constants
       1
Fatal Error: Wrong module version '0' (expected '9') for file 'module_model_constants.mod' opened at (1)
make[2]: [../phys/module_physics_init.o] Error 1 (ignored)
module_advect_em.f90:2.6:

  USE module_bc
      1
Fatal Error: Wrong module version '0' (expected '9') for file 'module_bc.mod' opened at (1)
make[2]: [module_advect_em.o] Error 1 (ignored)
module_big_step_utilities_em.f90:2.7:

   USE module_domain, ONLY : domain
       1
Fatal Error: Wrong module version '0' (expected '9') for file 'module_domain.mod' opened at (1)
make[2]: [module_big_step_utilities_em.o] Error 1 (ignored)
module_small_step_em.f90:2.7:

   USE module_configure
       1
Fatal Error: Wrong module version '0' (expected '9') for file 'module_configure.mod' opened at (1)
make[2]: [module_small_step_em.o] Error 1 (ignored)
module_bc_em.f90:2.7:

   USE module_bc
       1
Fatal Error: Wrong module version '0' (expected '9') for file 'module_bc.mod' opened at (1)
make[2]: [module_bc_em.o] Error 1 (ignored)
module_sfs_driver.f90:6.6:

  USE module_domain
      1
Fatal Error: Wrong module version '0' (expected '9') for file 'module_domain.mod' opened at (1)
make[2]: [module_sfs_driver.o] Error 1 (ignored)
adapt_timestep_em.f90:2.6:

  USE module_domain
      1
Fatal Error: Wrong module version '0' (expected '9') for file 'module_domain.mod' opened at (1)
make[2]: [adapt_timestep_em.o] Error 1 (ignored)
start_em.f90:22.7:

   USE module_domain, ONLY : domain, wrfu_timeinterval, get_ijk_from_grid, &
       1
Fatal Error: Wrong module version '0' (expected '9') for file 'module_domain.mod' opened at (1)
make[2]: [start_em.o] Error 1 (ignored)
module_em.f90:2.7:

   USE module_model_constants
       1
Fatal Error: Wrong module version '0' (expected '9') for file 'module_model_constants.mod' opened at (1)
make[2]: [module_em.o] Error 1 (ignored)
module_diffusion_em.f90:2.8:

    USE module_configure
        1
Fatal Error: Wrong module version '0' (expected '9') for file 'module_configure.mod' opened at (1)
make[2]: [module_diffusion_em.o] Error 1 (ignored)
module_first_rk_step_part1.f90:29.8:

    USE module_model_constants
        1
Fatal Error: Wrong module version '0' (expected '9') for file 'module_model_constants.mod' opened at (1)
make[2]: [module_first_rk_step_part1.o] Error 1 (ignored)
module_first_rk_step_part2.f90:30.8:

    USE module_model_constants
        1
Fatal Error: Wrong module version '0' (expected '9') for file 'module_model_constants.mod' opened at (1)
make[2]: [module_first_rk_step_part2.o] Error 1 (ignored)
solve_em.f90:11.7:

   USE module_domain, ONLY : &
       1
Fatal Error: Wrong module version '0' (expected '9') for file 'module_domain.mod' opened at (1)
make[2]: [solve_em.o] Error 1 (ignored)
ar: creating ../main/libwrflib.a
ar: module_advect_em.o: No such file or directory
make[2]: [dyn_em] Error 1 (ignored)
ranlib: 'libwrflib.a': No such file
make[1]: [em_wrf] Error 1 (ignored)
gfortran: error: libwrflib.a: No such file or directory
make[1]: [em_wrf] Error 1 (ignored)
../dyn_em/module_initialize_real.f90:2.7:

   USE module_bc
       1
Fatal Error: Wrong module version '0' (expected '9') for file 'module_bc.mod' opened at (1)
make[1]: [../dyn_em/module_initialize_real.o] Error 1 (ignored)
../frame/module_domain.f90:4.7:

   USE module_configure
       1
Fatal Error: Wrong module version '0' (expected '9') for file 'module_configure.mod' opened at (1)
make[2]: [../frame/module_domain.o] Error 1 (ignored)
../frame/module_configure.f90:4.6:

  USE module_domain_type, ONLY : streamrec
      1
Fatal Error: Wrong module version '0' (expected '9') for file 'module_domain_type.mod' opened at (1)
make[2]: [../frame/module_configure.o] Error 1 (ignored)
nest_init_utils.f90:2.7:

   USE module_domain, ONLY : domain
       1
Fatal Error: Wrong module version '0' (expected '9') for file 'module_domain.mod' opened at (1)
make[2]: [nest_init_utils.o] Error 1 (ignored)
../frame/module_dm.f90:3.7:

   USE module_wrf_error
       1
Fatal Error: Wrong module version '0' (expected '9') for file 'module_wrf_error.mod' opened at (1)
make[2]: [../frame/module_dm.o] Error 1 (ignored)
../share/module_io_domain.f90:2.4:

USE module_io
    1
Fatal Error: Wrong module version '0' (expected '9') for file 'module_io.mod' opened at (1)
make[2]: [../share/module_io_domain.o] Error 1 (ignored)
../share/module_bc.f90:2.7:

   USE module_configure
       1
Fatal Error: Wrong module version '0' (expected '9') for file 'module_configure.mod' opened at (1)
make[2]: [../share/module_bc.o] Error 1 (ignored)
../share/module_soil_pre.f90:2.7:

   USE module_date_time
       1
Fatal Error: Wrong module version '0' (expected '9') for file 'module_date_time.mod' opened at (1)
make[2]: [../share/module_soil_pre.o] Error 1 (ignored)
../share/module_optional_input.f90:28.10:

      USE module_domain , ONLY : domain
          1
Fatal Error: Wrong module version '0' (expected '9') for file 'module_domain.mod' opened at (1)
make[2]: [../share/module_optional_input.o] Error 1 (ignored)
module_initialize_real.f90:10.7:

   USE module_bc
       1
Fatal Error: Wrong module version '0' (expected '9') for file 'module_bc.mod' opened at (1)
make[2]: [module_initialize_real.o] Error 1 (ignored)
../frame/module_domain.f90:4.7:

   USE module_configure
       1
Fatal Error: Wrong module version '0' (expected '9') for file 'module_configure.mod' opened at (1)
make[1]: [../frame/module_domain.o] Error 1 (ignored)
../frame/module_configure.f90:4.6:

  USE module_domain_type, ONLY : streamrec
      1
Fatal Error: Wrong module version '0' (expected '9') for file 'module_domain_type.mod' opened at (1)
make[1]: [../frame/module_configure.o] Error 1 (ignored)
../frame/module_dm.f90:3.7:

   USE module_wrf_error
       1
Fatal Error: Wrong module version '0' (expected '9') for file 'module_wrf_error.mod' opened at (1)
make[1]: [../frame/module_dm.o] Error 1 (ignored)
../frame/module_integrate.f90:4.7:

   USE module_domain
       1
Fatal Error: Wrong module version '0' (expected '9') for file 'module_domain.mod' opened at (1)
make[1]: [../frame/module_integrate.o] Error 1 (ignored)
../share/module_bc.f90:2.7:

   USE module_configure
       1
Fatal Error: Wrong module version '0' (expected '9') for file 'module_configure.mod' opened at (1)
make[1]: [../share/module_bc.o] Error 1 (ignored)
../share/module_io_domain.f90:2.4:

USE module_io
    1
Fatal Error: Wrong module version '0' (expected '9') for file 'module_io.mod' opened at (1)
make[1]: [../share/module_io_domain.o] Error 1 (ignored)
../share/module_soil_pre.f90:2.7:

   USE module_date_time
       1
Fatal Error: Wrong module version '0' (expected '9') for file 'module_date_time.mod' opened at (1)
make[1]: [../share/module_soil_pre.o] Error 1 (ignored)
../dyn_em/module_big_step_utilities_em.f90:2.7:

   USE module_domain, ONLY : domain
       1
Fatal Error: Wrong module version '0' (expected '9') for file 'module_domain.mod' opened at (1)
make[1]: [../dyn_em/module_big_step_utilities_em.o] Error 1 (ignored)
ndown_em.f90:3.7:

   USE module_domain, ONLY : domain, head_grid, alloc_and_configure_domain, &
       1
Fatal Error: Wrong module version '0' (expected '9') for file 'module_domain.mod' opened at (1)
make[1]: [ndown_em.o] Error 1 (ignored)
nup_em.f90:3.7:

   USE module_domain, ONLY : domain, wrfu_timeinterval, alloc_and_configure_dom
       1
Fatal Error: Wrong module version '0' (expected '9') for file 'module_domain.mod' opened at (1)
make[1]: [nup_em.o] Error 1 (ignored)
../share/module_date_time.f90:2.6:

  USE module_wrf_error
      1
Fatal Error: Wrong module version '0' (expected '9') for file 'module_wrf_error.mod' opened at (1)
make[1]: [../share/module_date_time.o] Error 1 (ignored)
../share/module_optional_input.f90:28.10:

      USE module_domain , ONLY : domain
          1
Fatal Error: Wrong module version '0' (expected '9') for file 'module_domain.mod' opened at (1)
make[1]: [../share/module_optional_input.o] Error 1 (ignored)
tc_em.f90:3.7:

   USE module_domain, ONLY : domain, alloc_and_configure_domain, &
       1
Fatal Error: Wrong module version '0' (expected '9') for file 'module_domain.mod' opened at (1)
make[1]: [tc_em.o] Error 1 (ignored)
ranlib: 'libwrflib.a': No such file
make[1]: [em_real] Error 1 (ignored)
gfortran: error: ../dyn_em/module_initialize_real.o: No such file or directory
gfortran: error: libwrflib.a: No such file or directory
make[1]: [em_real] Error 1 (ignored)
gfortran: error: ndown_em.o: No such file or directory
gfortran: error: ../dyn_em/module_initialize_real.o: No such file or directory
gfortran: error: libwrflib.a: No such file or directory
make[1]: [em_real] Error 1 (ignored)
gfortran: error: nup_em.o: No such file or directory
gfortran: error: ../dyn_em/module_initialize_real.o: No such file or directory
gfortran: error: libwrflib.a: No such file or directory
make[1]: [em_real] Error 1 (ignored)
gfortran: error: tc_em.o: No such file or directory
gfortran: error: ../dyn_em/module_initialize_real.o: No such file or directory
gfortran: error: libwrflib.a: No such file or directory
make[1]: [em_real] Error 1 (ignored)

 

 

تصویر moje.am

من تا به حال این نرم افزار رو نصب نکردم. آیا آپشن خاصی از اون رو در نظر دارید یا همه چیز به حالت پیش‌فرض هست؟ تلاش میکنم اون رو نصب کنم، شاید در جریان نصب بتونم مشکل شما رو هم حل کنم.

تصویر arezu

 راستش من می خوام گردو غبار رو به وسیله ی wrf-chem ردیابی کنم. منتها باید قبل اینکه کار خاصی بکنم مدل رو کوپل کنم. همه ی این ارور ها مربوط به مرحله کامپایل هستش.

واقعا از لطفتون ممنونم.

تصویر nixmd

error مشاهده کردید؟ یا warning ؟

برای ارسال دیدگاه وارد شوید یا ثبت نام کنید .